Site bugged when using iOS Safari?

Report bugs and share your ideas to improve WarcraftPets.
Post Reply
User avatar
Opteron
MVP
Posts: 293
Joined: May 5th, 2014
Pet Score: 9685
BattleTag®: Opteron#1953
Realm: Lightninghoof-US
Contact:

Site bugged when using iOS Safari?

Post by Opteron » March 13th, 2015, 12:24 am

Hi all, starting today, I can't see any page from WCP website when using my iPhone Safari.
The page opens up, but immediatley after that, it loads an ad on top of the wcp page.
Was there anything new that could cause this behavior?
Thanks and regards, Opteron
Image

User avatar
Breanni
Site Admin
Posts: 471
Joined: December 1st, 2007
Pet Score: 1499
Realm: Scarlet Crusade-US
Contact:

Re: Site bugged when using iOS Safari?

Post by Breanni » March 23rd, 2015, 7:05 am

It must be related to the specific ad that's being served. I've disabled ads on your account for the next 90 days -- let us know if you continue to experience any problems.
Image

User avatar
Melmo
MVP
Posts: 454
Joined: May 24th, 2012
Pet Score: 7990
BattleTag®: Melmo#1842
Realm: Whisperwind-US
Contact:

Re: Site bugged when using iOS Safari?

Post by Melmo » March 23rd, 2015, 8:26 am

I have this issue as well on Safari for iPhone... I even downloaded a new browser from the iTunes app store and it still happens >_>
Image

Deadpoint
Posts: 7
Joined: February 24th, 2015
Pet Score: 4562
Realm: Kilrogg-US
Contact:

Re: Site bugged when using iOS Safari?

Post by Deadpoint » April 1st, 2015, 10:14 am

I'm getting a similar issue. It's even shutting down the browser and opening up the App Store pages for various apps. Makes the site unusable for me. Took three attempts to post this. :(

User avatar
Skippythecloud
Posts: 1
Joined: July 9th, 2014
Pet Score: 5822
Realm: Lothar-US
Contact:

Re: Site bugged when using iOS Safari?

Post by Skippythecloud » April 2nd, 2015, 1:59 pm

I agree I love this site, but right now it is unusable in ISO. Any interaction launches an ad/sponsored app.

User avatar
Yazhi
MVP
Posts: 0
Joined: February 12th, 2011
Pet Score: 4810
Realm: Emerald Dream-EU
Contact:

Re: Site bugged when using iOS Safari?

Post by Yazhi » April 3rd, 2015, 4:04 am

I had a similar thing this morning, whenever I tried to open Warcraftpets.com on my iphone a popup appeared for a quiz prize or something.

Half asleep I poked the screen to clear it away, and have now received a text saying I've been charged £15 for the privilege...

Trying to fix it with my phone provider atm -.-

This is only appearing on warcraftpets.com though no other pages (tested) though I'm unsure how it could be related....

User avatar
Kpb321
Posts: 938
Joined: April 30th, 2013
Pet Score: 3974
BattleTag®: kpb#1554
Realm: Sisters of Elune-US
Contact:

Re: Site bugged when using iOS Safari?

Post by Kpb321 » April 3rd, 2015, 11:38 am

I'm sure it's related to some bad ad. The problem is trying to identify the ad.

User avatar
Breanni
Site Admin
Posts: 471
Joined: December 1st, 2007
Pet Score: 1499
Realm: Scarlet Crusade-US
Contact:

Re: Site bugged when using iOS Safari?

Post by Breanni » April 16th, 2015, 3:45 am

The problem is catching the culprit -- it's not easy, especially on iOS. I'm going to speak to our ad network to see if anything else can be done.
Image

User avatar
Kpb321
Posts: 938
Joined: April 30th, 2013
Pet Score: 3974
BattleTag®: kpb#1554
Realm: Sisters of Elune-US
Contact:

Re: Site bugged when using iOS Safari?

Post by Kpb321 » April 16th, 2015, 11:23 am

I've run into this once or twice on my iPhone but since I don't have a Mac or anyway to do the debugging I wasn't able to capture the identifying code. At this point I'm pretty sure the "Evil Ads" know this and target iOS for that reason. They don't do the same thing on desktop browsers or other platforms to avoid detection.

Post Reply